EDT presentation issues

Comments

11 comments

  • Vladimir Gurov
    Dear Alexey,

    Do I understand you correctly that on your computer, in the Windows display settings, you have to specify the 2560x1440 resolution, 150% scaling, and the Program DPI setting enabled in order to make EDT display data without distortions?

    If not, please clarify the details.

    Also, please let us know:

    - 1C:Enterprise platform: version and bitness
    - 1C:Enterprise Development Tools: version


    Best regards,
    Vladimir Gurov
    0
    Comment actions Permalink
  • Alexey Gerasimov
    You are correct.

    I have several version of 1c:Ent installed.
    EDT 1.9.3.53
    0
    Comment actions Permalink
  • Vladimir Gurov
    Dear Alexey,

    Could you please install EDT 1.10.1.43, try to reproduce the issue you described, and let us know the results?

    Also, please inform us about the monitor model you use.

    Best regards,
    Vladimir Gurov
    0
    Comment actions Permalink
  • Alexey Gerasimov
    Vladimir, I really don't want to try 1.10 because it uses another format for storing project files ant it is impossible to downgrade EDT then.
    The monitor is Dell P2418D (2560x1440)

    Also please ask developers to correct the error

    Code
    If XMLReader.NodeType = XMLNodeType.StartElement then
    

    Quote
    XMLNodeType is not defined on WebClient
    , but in reality it does.
    0
    Comment actions Permalink
  • Alexey Gerasimov
    Also, please, please, pleeeeaase... correct all the import errors like:
    Quote
    Designer operation error occurred
    Template.xml
    , reason:
    Error converting XDTO data:
    Value: {http://v8.1c.ru/8.1/data/ui/style}CompletedJob Type: {http://v8.1c.ru/8.1/data/ui}Color
    , reason:
    XDTO type mapping on V8 type is missing:
    Mapping lexical value '{http://v8.1c.ru/8.1/data/ui/style}CompletedJob' to value type 'Color'

    It is so difficult to find what is wrong and need to be corrected
    0
    Comment actions Permalink
  • Vladimir Gurov
    Dear Alexey,

    As for the issues you declared in messages #5 and #6, our developers are considering them.

    As for the issue with incorrect scaling. We could not reproduce the issue. As you reproduced it with your project in EDT 1.9.x and insist that we should consider and fix the issue, please verify you can reproduce the issue in EDT 1.10.x. The only major version of EDT where we fix issues now is 1.10.x.

    Best regards,
    Vladimir Gurov
    0
    Comment actions Permalink
  • Vladimir Gurov
    Dear Alexey,

    "XMLNodeType is not defined on WebClient"

    We checked this and could not reproduce the issue. Here is what we did:

    https://mega.nz/#!ze4XFQjb!jvC1oEPIHIT18fEPra2oRvsUZ0hp7uBIHIn81-BIo-k
    https://mega.nz/#!rC5nXKYB!hCs91WS2lpRDZaLn227ZPDsTGy-WiLPLZKgoNLiFN8A
    https://mega.nz/#!zGplmQ5I!mSSSe8pWkMgX_dW-nVaJ-JZvmbIdWB1rcYZWtaLeKKk


    Could you please specify the example (including the infobase) where you reproduced the issue?

    Best regards,
    Vladimir Gurov
    0
    Comment actions Permalink
  • Alexey Gerasimov
    Quote
    Vladimir Gurov wrote:
    "XMLNodeType is not defined on WebClient"

    We checked this and could not reproduce the issue. Here is what we did:

    I think you are right about this one. We had this code for several years without any warning from Designer and it worked fine, but it could probably be due to the great luck that nobody has executed this part of the code on WebClient. Strangely I think I saw WebClient in the list of the supported modes of execution before writing to the forum, probably I saw Mobile client and not Web client. Sorry for extra work I have made you to perform.
    0
    Comment actions Permalink
  • Alexey Gerasimov
    Self-explanatory

    0
    Comment actions Permalink
  • Alexey Gerasimov
    Quote
    Vladimir Gurov wrote:
    As for the issue with incorrect scaling. We could not reproduce the issue. As you reproduced it with your project in EDT 1.9.x and insist that we should consider and fix the issue, please verify you can reproduce the issue in EDT 1.10.x. The only major version of EDT where we fix issues now is 1.10.x.
    So, please upload latest versions to 1c-dn so we could test them. I can see that 1C:Enterprise Development Tools 1.10.2.57 was released on 29.04.19 but it is still not uploaded (I do not have rights to download it from users.v8).
    0
    Comment actions Permalink
  • Vladimir Gurov
    Dear Alexey,

    1C:Enterprise Development Tools 1.10.2.57 is published.

    Best regards,
    Vladimir Gurov
    0
    Comment actions Permalink

Please sign in to leave a comment.